FiiO E17 to PC running Windows XP

Discussion in 'Ask The Experts' started by The Waddon, Jun 12, 2012.

  1. The Waddon

    The Waddon New Member

    Jun 12, 2012
    Hi. Can I ask for help please!

    Have just bought an FiiO E17 from hifi headphones and am very happy with the amp when connected via an L9 line out cable to my iPhone4.

    But am having problems connecting it to my PC running Windows XP. Using the USB cable and opt for 'USB input' as required and connect. When I enter Control Panel - Sounds and Audio Devices - the E17 is now happily illustrated as my default playback device although strangely it does not show up as an 'icon' on My Computer. So - Properties display is illustrated. Click on Audio. Click on Advanced and opt for headphones output. At that point the E17 display changes from 48k 16bit to 96k 24bit. So far so good. Then try playing a track from Windows Media Mibrary and the E17 display reverts to 48k 16bit immediately.

    I cannot see a way to change that setting from the 48k 16bit to 96k 24bit. The PC E17 Properties display shows basic sound, audio and driver details only with no way of making any changes. Have tried this on two separate PC's using Windows XP. Youtube videos show that Windows 7 enables Managing Audio Devices to achieve this change to 96k 24bit.

    Can I effect the change here? I was recommended to use 'foobar' which I have downloaded. However when going to 'preferences and then playback I see no facility to change output settings.

    Would be grateful for any advice here because I am feeling pretty exasperated and disappointed at present!!!

  2. dalethorn

    dalethorn Active Member

    Jul 3, 2011
    Charleston South Carolina
    Have you confirmed that the track you want to play at 96k also plays at 96k on Foobar?

    Edit: Since you said "Playing a track from Windows Media library", what player does that use on the PC?
  3. The Waddon

    The Waddon New Member

    Jun 12, 2012
    E17 to PC

    Hi Dalethorn,

    Problem solved now. I received the advise below which I followed to the letter.

    It worked perfectly with fantastic results!

    'I think it's because Windows (correctly) recognizes that the source is 16/48 instead of 24/96. You would have to upsample it before passing it through the Windows sound kernel.
    In foobar2000, at least in my case, I can go to Preferences -> Playback -> Output and select 24-bit for "output format".
    The 96kHz sampling rate is achieved by running the signal through an upsampler DSP. Preferences -> Playback -> DSP Manager. Then add the Resampler (PPHS) plugin, which should come with standard installation of foobar2000. Click "Configure Selected" and set sampling rate to 96000'

    So - I am now a happy soul! Thanks for your post though.


Share This Page